Back to overview
Degraded

Service Disruptions Due to Global Widespread Outage

Oct 20 at 01:30am PDT
Affected services
System Access & Stability
Payments & Finances
Client Communication
AI Features
Files
Notifications

Resolved
Oct 20 at 03:47pm PDT

All of the affected services are back to normal, and the system is stable.
Thank you for your patience!

Updated
Oct 20 at 01:27pm PDT

We are seeing partial recovery of our systems and are working towards mitigation. As recovery continues, some users may experience slower performance or limited functionality.
While we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation.

Updated
Oct 20 at 10:04am PDT

Thank you for your continued patience. We understand the impact this issue is having on your operations and want to assure you that resolving this matter is our highest priority. Our teams are working closely with Amazon Web Services (AWS) and continuing efforts to stabilize the platform and reduce latency, but we expect users to continue to see periods of elevated latency and degraded performance until services are fully restored. While we do not have a definitive ETA at this time, we remain committed to full resolution and deeply appreciate your patience as we work through this situation.

Known affected services:

  • Clients ability to pay
  • Files and images upload
  • Custom domains creation
  • Mobile app notifications
  • Client Portal access
  • AI Features
  • Search and Reports generation
  • General latency in sending emails and loading some pages

Updated
Oct 20 at 07:43am PDT

We are actively working to restore normal operations after a widespread, global outage affecting multiple online platforms. As recovery continues, some users may experience slower performance or limited functionality.

Known affected services:

  • Files and images upload
  • Custom domains creation
  • Mobile app notifications
  • Client Portal access
  • AI Features
  • Search and Reports
  • General latency in sending emails and loading some pages

We appreciate your patience and will continue to provide updates every hour or sooner.

Updated
Oct 20 at 06:55am PDT

We are actively working to restore normal operations after a widespread, global outage affecting multiple online platforms. As recovery continues, some users may experience slower performance or limited functionality. Thank you for your patience! We’ll post updates as we learn more.

Updated
Oct 20 at 03:29am PDT

We are seeing partial recovery of our systems and are working towards mitigation. We will provide more updates as we confirm full recovery.

Updated
Oct 20 at 02:05am PDT

We are currently experiencing disruptions across several services, which appear to be related to a global outage affecting multiple online platforms.

Updated list of known impacted services so far:
* Files upload
* Custom domains creation
* Payments processing
* Mobile app notifications
* Client Portal
* AI Features

Updates will follow in an hourly cadence.

Created
Oct 20 at 01:30am PDT

We are currently experiencing disruptions across several services, which appear to be related to a global outage affecting multiple online platforms.

Known impacted services so far:
Upload of files, creating custom domains, payments processing

Updates will follow in an hourly cadence.