Back to overview
Degraded

issues opening files and inquiry forms

Nov 26 at 08:29am PST
Affected services
Leads Capture
Files

Resolved
Nov 26 at 09:07am PST

We have resolved the issue affecting access to files and inquiry forms. All files remain intact and should now open without any errors, including those previously impacted. We will continue to monitor the system to ensure everything remains stable.

Updated
Nov 26 at 08:52am PST

We’ve found the cause of the problem. It was related to a recent update and affected new files created from Lead Form submissions since yesterday.

We are currently working on a fix that will correct all affected files and ensure new files are created correctly going forward.

Created
Nov 26 at 08:29am PST

We are currently investigating an issue causing errors when users try to open files and inquiry forms. Our team is working to identify the root cause and restore full functionality as quickly as possible.

We apologize for the disruption and will provide an update as soon as more information is available.