Back to overview
Degraded
Some users unable to access projects
Nov 17 at 06:22am PST
Affected services
CRM & Project Management
Resolved
Nov 17 at 06:31am PST
The issue preventing some users from accessing their projects has been resolved. All projects are now accessible as usual, and we can confirm that no data was lost.
Thank you for your patience while we worked to fix this issue!
Affected services
Created
Nov 17 at 06:22am PST
We're currently investigating an issue where some users are being redirected to the home page when attempting to open their projects.
Our team is actively working to identify the cause and restore normal access. We'll provide updates as we learn more.
Affected services