Payment delays and duplicate notifications
Resolved
Aug 28 at 01:36pm PDT
We recently identified an issue that caused delays in some client payments. During the resolution, duplicate payment emails and notifications were unintentionally sent for invoices that had already been paid, which may have caused confusion about potential double charges.
These issues have now been resolved, and we are actively monitoring the system. Payment statuses are correctly reflected, and all held payouts have been released. Importantly, no duplicate charges occurred.
We are continuing to investigate a few known side effects:
1. Duplicate feed items for paid payments (fix in progress)
2. Payments duplicating in QuickBooks (fix in progress)
3. Duplicate payments appearing in reports (under investigation)
Affected services
Created
Aug 28 at 10:00am PDT
We identified an issue that affected how some payments were processed and displayed.
Payment Statuses and Payouts – Due to a temporary technical issue, some payment statuses were not updating correctly and certain payouts were delayed.
Duplicate Notifications – As part of recovering the affected payments, duplicate payment emails and notifications were unintentionally sent for several invoices that had already been completed.
We are working to restore all delayed payments fully. No duplicate charges occurred, and no funds were lost. The additional notifications did not impact the actual payments or balances.
Affected services