Back to overview
Resolved

Email communication temporarily queued

Aug 23, 2026 at 7:47pm UTC
Affected services
Client Communication
Automations & Integrations

Resolved
Aug 23, 2026 at 7:47pm UTC

All Emails were queued and will be delivered automatically. New emails are already sending normally, No data was lossed.